Vulnerability · Published Jun 13, 2023 · Assigned by GitHub_M
CVE-2023-32301Discourse's canonical url not being used for topic embeddings
Low 3.1
In plain English
A low-severity security flaw in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities).
Official description
Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, multiple duplicate topics could be created if topic embedding is enabled. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. As a workaround, disable topic embedding if it has been enabled.
Affected products (as reported)
Weakness: CWE-116 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
References
- https://github.com/discourse/discourse/security/advisories/GHSA-p2jx-m2j5-hqh4 x_refsource_CONFIRM