Vulnerability · Published May 10, 2023 · Assigned by GitHub_M

CVE-2023-32080Wings vulnerable to escape to host from installation container

Critical 9.1

In plain English

A critical-severity security flaw in wings from pterodactyl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.9%top 39.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Wings is the server control plane for Pterodactyl Panel. A vulnerability affecting versions prior to 1.7.5 and versions 1.11.0 prior to 1.11.6 impacts anyone running the affected versions of Wings. This vulnerability can be used to gain access to the host system running Wings if a user is able to modify an server's install script or the install script executes code supplied by the user (either through environment variables, or commands that execute commands based off of user data). This vulnerability has been resolved in version `v1.11.6` of Wings, and has been back-ported to the 1.7 release series in `v1.7.5`. Anyone running `v1.11.x` should upgrade to `v1.11.6` and anyone running `v1.7.x` should upgrade to `v1.7.5`. There are no workarounds aside from upgrading. Running Wings with a rootless container runtime may mitigate the severity of any attacks, however the majority of users are using container runtimes that run as root as per the Wings documentation. SELinux may prevent attackers from performing certain operations against the host system, however privileged containers have a lot of freedom even on systems with SELinux enabled. It should be noted that this was a known attack vector, for attackers to easily exploit this attack it would require compromising an administrator account on a Panel. However, certain eggs (the data structure that holds the install scripts that get passed to Wings) have an issue where they are unknowingly executing shell commands with escalated privileges provided by untrusted user data.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/pterodactyl/wings1.7.5GHSA-p744-4q6p-hvc2
Gogithub.com/pterodactyl/wings1.11.6GHSA-p744-4q6p-hvc2
Gogithub.com/pterodactyl/wings1.11.6, 1.7.5GO-2023-1768

Affected products (as reported)

VendorProductVersions
pterodactyl wings < 1.7.5>= 1.11.0, < 1.11.6

Weakness: CWE-250 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References