Vulnerability · Published Aug 24, 2023 · Assigned by GitHub_M
CVE-2023-32079Netmaker Privilige Escalation Vulnerability
High 8.8
In plain English
A high-severity security flaw in netmaker from gravitl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netmaker makes networks with WireGuard. A Mass assignment vulnerability was found in versions prior to 0.17.1 and 0.18.6 that allows a non-admin user to escalate privileges to those of an admin user. The issue is patched in 0.17.1 and fixed in 0.18.6. If Users are using 0.17.1, they should run `docker pull gravitl/netmaker:v0.17.1` and `docker-compose up -d`. This will switch them to the patched users If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. As a workaround, someone using version 0.17.1 can pull the latest docker image of the backend and restart the server.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/gravitl/netmaker | 0.17.1 | GHSA-826j-8wp2-4x6q |
| Go | github.com/gravitl/netmaker | 0.18.6 | GHSA-826j-8wp2-4x6q |
| Go | github.com/gravitl/netmaker | 0.17.1, 0.18.6 | GO-2023-2025 |
Affected products (as reported)
Weakness: CWE-915 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/gravitl/netmaker/security/advisories/GHSA-826j-8wp2-4x6q x_refsource_CONFIRM