Vulnerability · Published May 9, 2023 · Assigned by GitHub_M

CVE-2023-32071XWiki Platform vulnerable to RXSS via editor parameter - importinline template

Critical 9.1

In plain English

A critical-severity cross-site scripting in xwiki-platform from xwiki. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 70.4% (higher than 99.4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)70.4%top 0.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

XWiki Platform is a generic wiki platform. Starting in versions 2.2-milestone-1 and prior to versions 14.4.8, 14.10.4, and 15.0-rc-1, it's possible to execute javascript with the right of any user by leading him to a special URL on the wiki targeting a page which contains an attachment. This has been patched in XWiki 15.0-rc-1, 14.10.4, and 14.4.8. The easiest possible workaround is to edit file `<xwiki app>/templates/importinline.vm` and apply the modification described in commit 28905f7f518cc6f21ea61fe37e9e1ed97ef36f01.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-distribution-war14.4.8GHSA-j9h5-vcgv-2jfm
Mavenorg.xwiki.platform:xwiki-platform-distribution-war14.10.4GHSA-j9h5-vcgv-2jfm

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform >= 2.2-milestone-1, < 14.4.8>= 14.5, < 14.10.4

Weakness: CWE-116, CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

References