Vulnerability · Published Jun 20, 2024 · Assigned by Wordfence
CVE-2023-3204Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update
Medium 6.5
In plain English
A medium-severity missing authorization in Materialis from extendthemes. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities).
Official description
The Materialis theme for WordPress is vulnerable to limited arbitrary options updates in versions up to, and including, 1.1.24. This is due to missing authorization checks on the companion_disable_popup() function called via an AJAX action. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to modify any option on the site to a numerical value.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| extendthemes | Materialis | 0 – through 1.1.24 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a2e05094-8344-4388-a703-518daf3d2948?source=cve
- https://themes.trac.wordpress.org/browser/materialis/1.1.20/inc/companion.php#L45
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=231816%40materialis&new=231816%40materialis&sfp_email=&sfph_mail=#file6