Vulnerability · Published May 8, 2023 · Assigned by GitHub_M

CVE-2023-30837Vyper storage allocator overflow

High 7.5

In plain English

A high-severity security flaw in vyper from vyperlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 46.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vyper is a pythonic smart contract language for the EVM. The storage allocator does not guard against allocation overflows in versions prior to 0.3.8. An attacker can overwrite the owner variable. This issue was fixed in version 0.3.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvyper0.3.8GHSA-mgv8-gggw-mrg6
PyPIvyper0.3.8PYSEC-2023-76

Affected products (as reported)

VendorProductVersions
vyperlang vyper < 0.3.8

Weakness: CWE-789 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References