Vulnerability · Published May 30, 2023 · Assigned by apache
CVE-2023-30601Apache Cassandra: Privilege escalation when enabling FQL/Audit logs
High 7.8
In plain English
A high-severity privilege mismanagement in Apache Cassandra from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1. WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users. MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.cassandra:cassandra-all | 4.1.2 | GHSA-m9p2-j4hg-g373 |
| Maven | org.apache.cassandra:cassandra-all | 4.0.10 | GHSA-m9p2-j4hg-g373 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Cassandra | 4.0.0 – through 4.0.94.1.0 – through 4.1.1 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/f74p9jdhmmp7vtrqd8lgm8bq3dhxl8vn vendor-advisory