Vulnerability · Published Apr 17, 2023 · Assigned by GitHub_M

CVE-2023-30536Insecure header validation in slim/psr7

Medium 6.5

In plain English

A medium-severity security flaw in Slim-Psr7 from slimphp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.7%top 45.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. The issue has been patched in version 1.6.1. There are no known workarounds to this issue. Users are advised to upgrade.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-slim-psr71.6.1-1DEBIAN-CVE-2023-30536
Debian:13php-slim-psr71.6.1-1DEBIAN-CVE-2023-30536
Debian:14php-slim-psr71.6.1-1DEBIAN-CVE-2023-30536
Packagistslim/psr71.5.1GHSA-q2qj-628g-vhfw
Packagistslim/psr71.4.1GHSA-q2qj-628g-vhfw
Packagistslim/psr71.6.1GHSA-q2qj-628g-vhfw
Ubuntu:24.04:LTSphp-slim-psr7no fix listedUBUNTU-CVE-2023-30536

Affected products (as reported)

VendorProductVersions
slimphp Slim-Psr7 < 1.6.1

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

References