Vulnerability · Published Apr 10, 2023 · Assigned by apache
CVE-2023-29216Apache Linkis DatasourceManager module has a deserialization command execution
Critical 9.8
In plain English
A critical-severity unsafe deserialization in Apache Linkis from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.linkis:linkis-datasource | 1.3.2 | GHSA-rrhf-32rq-f28h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Linkis | 0 – through 1.3.1 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l vendor-advisory, mailing-list
- http://www.openwall.com/lists/oss-security/2023/04/10/5