Vulnerability · Published Apr 25, 2023 · Assigned by GitHub_M
CVE-2023-29200contao/core-bundle has path traversal vulnerability in the file manager
Medium 4.3
In plain English
A medium-severity path traversal in contao from contao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | contao/contao | 4.9.40 | GHSA-fp7q-xhhw-6rj3 |
| Packagist | contao/contao | 4.13.21 | GHSA-fp7q-xhhw-6rj3 |
| Packagist | contao/contao | 5.1.4 | GHSA-fp7q-xhhw-6rj3 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N