Vulnerability · Published Apr 17, 2023 · Assigned by GitHub_M

CVE-2023-29197Improper header name validation in guzzlehttp/psr7

Medium 5.3

In plain English

A medium-severity security flaw in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.2%top 31.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-guzzlehttp-psr72.4.5-1DEBIAN-CVE-2023-29197
Debian:13php-guzzlehttp-psr72.4.5-1DEBIAN-CVE-2023-29197
Debian:14php-guzzlehttp-psr72.4.5-1DEBIAN-CVE-2023-29197
Debian:12php-nyholm-psr71.5.1-2DEBIAN-CVE-2023-29197
Debian:13php-nyholm-psr71.5.1-2DEBIAN-CVE-2023-29197
Debian:14php-nyholm-psr71.5.1-2DEBIAN-CVE-2023-29197
Packagistguzzlehttp/psr72.4.5GHSA-wxmh-65f7-jcvw
Packagistguzzlehttp/psr71.9.1GHSA-wxmh-65f7-jcvw

Affected products (as reported)

VendorProductVersions
guzzle psr7 < 1.9.1>= 2.0.0, < 2.4.5

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References