Vulnerability · Published Apr 6, 2023 · Assigned by GitHub_M
CVE-2023-29015Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments
Medium 6.1
In plain English
A medium-severity cross-site scripting in goobi-viewer-core from intranda. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A cross-site scripting vulnerability has been identified in the user comment feature of Goobi viewer core prior to version 23.03. An attacker could create a specially crafted comment, resulting in the execution of malicious script code in the user's browser when displaying the comment. The vulnerability has been fixed in version 23.03.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | io.goobi.viewer:viewer-core | 23.03 | GHSA-622w-995c-3c3h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| intranda | goobi-viewer-core | < 23.03 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N