Vulnerability · Published Mar 27, 2023 · Assigned by mitre

CVE-2023-28867

High 7.5

In plain English

A high-severity security flaw in the com.graphql-java:graphql-java package (Maven). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)7.5High
Exploit odds (30 days)1.1%top 35.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavencom.graphql-java:graphql-java0.0.0-2023-03-20T01-49-44-80e3135GHSA-p4qx-6w5p-4rj2
Mavencom.graphql-java:graphql-java17.5GHSA-p4qx-6w5p-4rj2
Mavencom.graphql-java:graphql-java18.4GHSA-p4qx-6w5p-4rj2
Mavencom.graphql-java:graphql-java19.4GHSA-p4qx-6w5p-4rj2
Mavencom.graphql-java:graphql-java20.1GHSA-p4qx-6w5p-4rj2

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

References