Vulnerability · Published Mar 30, 2023 · Assigned by GitHub_M
CVE-2023-28835Insecure randomness for default password in nextcloud
Low 3.5
In plain English
A low-severity security flaw in security-advisories from nextcloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).
Official description
Nextcloud server is an open source home cloud implementation. In affected versions the generated fallback password when creating a share was using a weak complexity random number generator, so when the sharer did not change it the password could be guessable to an attacker willing to brute force it. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. This issue only affects users who do not have a password policy enabled, so enabling a password policy is an effective mitigation for users unable to upgrade.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| nextcloud | security-advisories | < 24.0.10>= 25.0.0, < 25.0.4 |
Weakness: CWE-338 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7w2p-rp9m-9xp9 x_refsource_CONFIRM
- https://github.com/nextcloud/server/pull/36093 x_refsource_MISC