Vulnerability · Published Mar 20, 2023 · Assigned by GitHub_M

CVE-2023-28429Pimcore has Cross-site Scripting vulnerability in DataObject tooltip field

Medium 6.1

In plain English

A medium-severity cross-site scripting in pimcore from pimcore. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.5%top 54.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pimcore is an open source data and experience management platform. Versions prior to 10.5.19 have an unsecured tooltip field in DataObject class definition. This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Users should upgrade to version 10.5.19 or, as a workaround, apply the patch manually.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistpimcore/pimcore10.5.19GHSA-rcg9-hrhx-6q69

Affected products (as reported)

VendorProductVersions
pimcore pimcore < 10.5.19

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References