Vulnerability · Published Apr 12, 2023 · Assigned by hackerone

CVE-2023-28121

Critical 9.8

In plain English

A critical-severity improper authentication in WooCommerce Payments WordPress Plugin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 87.4% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)87.4%top 0.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling3Metasploit, Nuclei, Public PoC

Official description

An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.

Affected products (as reported)

VendorProductVersions
n/a WooCommerce Payments WordPress Plugin Fixed version 5.6.2

Weakness: CWE-287

References