Vulnerability · Published Mar 16, 2023 · Assigned by GitHub_M

CVE-2023-28113russh may use insecure Diffie-Hellman keys

Medium 5.9

In plain English

A medium-severity improper input validation in russh from warp-tech. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities).

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.6%top 49.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1

Affected products (as reported)

VendorProductVersions
warp-tech russh 0.34.0 – before 0.34.0*0.36.2 – before 0.36.20.37.0 – before 0.37.0*0.37.1 – before 0.37.1

Weakness: CWE-20, CWE-358 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

References