Vulnerability · Published Mar 16, 2023 · Assigned by GitHub_M
CVE-2023-28110JumpServer Koko vulnerable to Command Injection for Kubernetes Connection
Medium 5.7
In plain English
A medium-severity command injection in jumpserver from jumpserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities).
Official description
Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jumpserver | jumpserver | < 2.28.8 |
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-6x5p-jm59-jh29 x_refsource_CONFIRM
- https://github.com/jumpserver/jumpserver/releases/tag/v2.28.8 x_refsource_MISC