Vulnerability · Published Mar 17, 2023 · Assigned by GitHub_M
CVE-2023-28107Discourse vulnerable to multisite DoS by spamming backups
Medium 4.5
In plain English
A medium-severity resource allocation without limits in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 51% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H
References
- https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx x_refsource_CONFIRM
- https://github.com/discourse/discourse/pull/20700 x_refsource_MISC
- https://github.com/discourse/discourse/pull/20701 x_refsource_MISC
- https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9 x_refsource_MISC
- https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61 x_refsource_MISC