Vulnerability · Published Feb 28, 2023 · Assigned by mitre

CVE-2023-27372

Critical 9.8

In plain English

A critical-severity unsafe deserialization in the spip package (Debian). Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 99.7% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)99.7%top 0.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling3Metasploit, Nuclei, Public PoC

Official description

SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13spip4.1.8+dfsg-1DEBIAN-CVE-2023-27372
Debian:14spip4.1.8+dfsg-1DEBIAN-CVE-2023-27372
Ubuntu:22.04:LTSspipno fix listedUBUNTU-CVE-2023-27372

Affected products (as reported)

VendorProductVersions
n/a n/a n/a

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References