Vulnerability · Published Mar 2, 2023 · Assigned by GitHub_M
CVE-2023-26053Gradle usage of long IDs for PGP keys opens potential for collision attacks
Medium 6.6
In plain English
A medium-severity security flaw in gradle from gradle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | gradle | 7.6.1-r0 | ALPINE-CVE-2023-26053 |
| Alpine:v3.21 | gradle | 7.6.1-r0 | ALPINE-CVE-2023-26053 |
| Alpine:v3.22 | gradle | 7.6.1-r0 | ALPINE-CVE-2023-26053 |
| Alpine:v3.23 | gradle | 7.6.1-r0 | ALPINE-CVE-2023-26053 |
| Alpine:v3.24 | gradle | 7.6.1-r0 | ALPINE-CVE-2023-26053 |
| Ubuntu:22.04:LTS | gradle | no fix listed | UBUNTU-CVE-2023-26053 |
| Ubuntu:24.04:LTS | gradle | no fix listed | UBUNTU-CVE-2023-26053 |
| Ubuntu:25.10 | gradle | no fix listed | UBUNTU-CVE-2023-26053 |
| Ubuntu:26.04:LTS | gradle | no fix listed | UBUNTU-CVE-2023-26053 |
| Ubuntu:26.10 | gradle | no fix listed | UBUNTU-CVE-2023-26053 |
Affected products (as reported)
Weakness: CWE-829 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H