Vulnerability · Published Feb 14, 2023 · Assigned by GitHub_M
CVE-2023-25567GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information
High 7.5
In plain English
A high-severity out-of-bounds read in gss-ntlmssp from gssapi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 66% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | gssntlmssp | 1.2.0-1.el8_8 | ALSA-2023:3097 |
| Debian:12 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25567 |
| Debian:13 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25567 |
| Debian:14 | gss-ntlmssp | 1.2.0-1 | DEBIAN-CVE-2023-25567 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| gssapi | gss-ntlmssp | < 1.2.0 |
Weakness: CWE-125 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H