Vulnerability · Published Feb 14, 2023 · Assigned by apache

CVE-2023-25141JNDI injection into Apache sling-org-apache-sling-jcr-base

High 7.5

In plain English

A high-severity injection in Apache Sling JCR Base from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.2%top 32.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.sling:org.apache.sling.jcr.base3.1.12GHSA-gvg3-83q4-rfhq

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Sling JCR Base 2.0.6 – before 3.1.12

Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References