Vulnerability · Published Feb 17, 2023 · Assigned by GitHub_M

CVE-2023-24809NetHack Call command buffer overflow

Medium 5.5

In plain English

A medium-severity buffer overflow in NetHack from NetHack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.5Medium
Exploit odds (30 days)0.2%top 85.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

NetHack is a single player dungeon exploration game. Starting with version 3.6.2 and prior to version 3.6.7, illegal input to the "C" (call) command can cause a buffer overflow and crash the NetHack process. This vulnerability may be a security issue for systems that have NetHack installed suid/sgid and for shared systems. For all systems, it may result in a process crash. This issue is resolved in NetHack 3.6.7. There are no known workarounds.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20nethack3.6.7-r0ALPINE-CVE-2023-24809
Alpine:v3.21nethack3.6.7-r0ALPINE-CVE-2023-24809
Alpine:v3.22nethack3.6.7-r0ALPINE-CVE-2023-24809
Alpine:v3.23nethack3.6.7-r0ALPINE-CVE-2023-24809
Alpine:v3.24nethack3.6.7-r0ALPINE-CVE-2023-24809
Debian:12nethackno fix listedDEBIAN-CVE-2023-24809
Debian:13nethack3.6.7-1DEBIAN-CVE-2023-24809
Debian:14nethack3.6.7-1DEBIAN-CVE-2023-24809
Ubuntu:22.04:LTSnethackno fix listedUBUNTU-CVE-2023-24809
Ubuntu:24.04:LTSnethackno fix listedUBUNTU-CVE-2023-24809
Ubuntu:25.10nethackno fix listedUBUNTU-CVE-2023-24809
Ubuntu:26.04:LTSnethackno fix listedUBUNTU-CVE-2023-24809
Ubuntu:26.10nethackno fix listedUBUNTU-CVE-2023-24809

Affected products (as reported)

VendorProductVersions
NetHack NetHack >= 3.6.2, < 3.6.7

Weakness: CWE-120 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References