Vulnerability · Published Feb 1, 2023 · Assigned by GitHub_M

CVE-2023-23630Cross-site (XSS) vulnerability with Express API in Eta

High 8.6

In plain English

A high-severity cross-site scripting in eta from eta-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.6%top 50.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Eta is an embedded JS templating engine that works inside Node, Deno, and the browser. XSS attack - anyone using the Express API is impacted. The problem has been resolved. Users should upgrade to version 2.0.0. As a workaround, don't pass user supplied things directly to `res.render`.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmeta2.0.0GHSA-xrh7-m5pp-39r6

Affected products (as reported)

VendorProductVersions
eta-dev eta < 2.0.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

References