Vulnerability · Published Jan 27, 2023 · Assigned by GitHub_M
CVE-2023-23627Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element
Medium 6.1
In plain English
A medium-severity cross-site scripting in sanitize from rgrove. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ruby-sanitize | 6.0.0-1.1 | DEBIAN-CVE-2023-23627 |
| Debian:13 | ruby-sanitize | 6.0.0-1.1 | DEBIAN-CVE-2023-23627 |
| Debian:14 | ruby-sanitize | 6.0.0-1.1 | DEBIAN-CVE-2023-23627 |
| RubyGems | sanitize | 6.0.1 | GHSA-fw3g-2h3j-qmm7 |
| Ubuntu:22.04:LTS | ruby-sanitize | 6.0.0-1ubuntu0.1 | USN-6748-1 |
| Ubuntu:22.04:LTS | ruby-sanitize | 6.0.0-1ubuntu0.1 | UBUNTU-CVE-2023-23627 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/rgrove/sanitize/security/advisories/GHSA-fw3g-2h3j-qmm7 x_refsource_CONFIRM