Actively exploited · Published Feb 27, 2023 · Assigned by apple
CVE-2023-23529
High 8.8 Exploited
In plain English
A high-severity type confusion in iOS and iPadOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on February 14, 2023). The chance it is exploited in the next 30 days is estimated at 9.4% (higher than 95% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
CISA guidance
Apply updates per vendor instructions.
Federal agencies must remediate by Mar 7, 2023.
Official description
A type confusion issue was addressed with improved checks. This issue is fixed in iOS 15.7.4 and iPadOS 15.7.4, iOS 16.3.1 and iPadOS 16.3.1, macOS Ventura 13.2.1, Safari 16.3. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.36.7-1.el8_7.2 | ALSA-2023:0902 |
| AlmaLinux:9 | webkit2gtk3 | 2.36.7-1.el9_1.2 | ALSA-2023:0903 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.36.7-1.el8_7.2 | ALSA-2023:0902 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.36.7-1.el9_1.2 | ALSA-2023:0903 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.36.7-1.el8_7.2 | ALSA-2023:0902 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.36.7-1.el9_1.2 | ALSA-2023:0903 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.36.7-1.el8_7.2 | ALSA-2023:0902 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.36.7-1.el9_1.2 | ALSA-2023:0903 |
| Debian:12 | webkit2gtk | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Debian:13 | webkit2gtk | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Debian:14 | webkit2gtk | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Debian:12 | wpewebkit | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Debian:13 | wpewebkit | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Debian:14 | wpewebkit | 2.38.5-1 | DEBIAN-CVE-2023-23529 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.36.7-1.el8_7.2 | RLSA-2023:0902 |
| Rocky Linux:9 | webkit2gtk3 | 0:2.36.7-1.el9_1.2 | RLSA-2023:0903 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-23529 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2023-23529 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.38.5-0ubuntu0.22.04.1 | UBUNTU-CVE-2023-23529 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.38.5-0ubuntu0.22.04.1 | USN-5893-1 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2023-23529 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apple | iOS and iPadOS | unspecified – before 16.3 |
| Apple | Safari | unspecified – before 16.3 |
| Apple | macOS | unspecified – before 13.2 |
| Apple | iOS and iPadOS | unspecified – before 15.7 |
Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H