Vulnerability · Published May 24, 2024 · Assigned by VulDB

CVE-2023-1001xuliangzhan vxe-table vxe-textarea textarea.js export cross site scripting

Low 3.5

In plain English

A low-severity cross-site scripting in vxe-table from xuliangzhan. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.3%top 71.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmvxe-table3.7.10GHSA-2qjp-fg8c-g878

Affected products (as reported)

VendorProductVersions
xuliangzhan vxe-table 3.7.03.7.13.7.23.7.33.7.43.7.53.7.63.7.7

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

References