Vulnerability · Published Mar 22, 2023 · Assigned by OpenNMS
CVE-2023-0870Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)
High 8.1
In plain English
A high-severity cross-site request forgery in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-webapp | 31.0.6 | GHSA-jxr6-7qg5-8wv6 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Meridian | 2020.1.0 – before 2020.1.332021.1.0 – before 2021.1.252022.1.0 – before 2022.1.142023.1.0 – before 2023.1.1 |
| The OpenNMS Group | Horizon | see references |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N