Vulnerability · Published Feb 23, 2023 · Assigned by OpenNMS
CVE-2023-0868Stealing Cookies using Reflected XSS via graph results
Medium 6.7
In plain English
A medium-severity improper input validation in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Reflected cross-site scripting in graph results in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to steal session cookies. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.opennms:opennms-webapp | 31.0.4 | GHSA-g57g-rvpg-2f2c |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| The OpenNMS Group | Meridian | 2022.1.0 – before 2023.1.0 |
| The OpenNMS Group | Horizon | 29.0.0 – through 31.0.3 |
Weakness: CWE-20, CWE-79 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N