Vulnerability · Published Feb 23, 2023 · Assigned by OpenNMS

CVE-2023-0867Multiple stored and reflected Cross-site Scripting in webapp

Medium 6.7

In plain English

A medium-severity cross-site scripting in Horizon from The OpenNMS Group. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.7Medium
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.opennms:opennms31.0.4GHSA-mjv2-6jv4-vrg7

Affected products (as reported)

VendorProductVersions
The OpenNMS Group Meridian 2020.1.0 – before 2020.1.322021.1.0 – before 2021.1.242022.1.0 – before 2022.1.13
The OpenNMS Group Horizon 26.0.0 – before 31.0.4

Weakness: CWE-79, CWE-20 · Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

References