Vulnerability · Published Jan 27, 2023 · Assigned by VulDB
CVE-2023-0549YAFNET Private Message PostPrivateMessage cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in YAFNET. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
A vulnerability, which was classified as problematic, has been found in YAFNET up to 3.1.10. This issue affects some unknown processing of the file /forum/PostPrivateMessage of the component Private Message Handler. The manipulation of the argument subject/message leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.1.11 is able to address this issue. The identifier of the patch is 2237a9d552e258a43570bb478a92a5505e7c8797. It is recommended to upgrade the affected component. The identifier VDB-219665 was assigned to this vulnerability.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.219665 vdb-entry, technical-description
- https://vuldb.com/?ctiid.219665 signature, permissions-required
- https://drive.google.com/drive/folders/1ct6Tp_cnsYO8L_JSvlBCf_Ae7KW3JAcD?usp=sharing exploit
- https://github.com/YAFNET/YAFNET/security/advisories/GHSA-4hwx-678w-9cp5 related
- https://github.com/YAFNET/YAFNET/commit/2237a9d552e258a43570bb478a92a5505e7c8797 patch
- https://github.com/YAFNET/YAFNET/releases/tag/v3.1.11 patch