Vulnerability · Published Apr 22, 2023 · Assigned by VulDB

CVE-2022-4944kalcaddle KodExplorer cross-site request forgery

Medium 4.3

In plain English

A medium-severity cross-site request forgery in KodExplorer from kalcaddle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)2.7%top 14.2% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack tooling1Public PoC

Official description

A vulnerability, which was classified as problematic, has been found in kalcaddle KodExplorer up to 4.49. Affected by this issue is some unknown functionality. The manipulation leads to cross-site request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.50 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-227000.

Affected products (as reported)

VendorProductVersions
kalcaddle KodExplorer 4.04.14.24.34.44.54.64.7

Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

References