Vulnerability · Published Jan 9, 2023 · Assigned by VulDB
CVE-2022-4882kaltura mwEmbed Share Plugin share.js cross site scripting
Low 2.6
In plain English
A low-severity cross-site scripting in mwEmbed from kaltura. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Official description
A vulnerability was found in kaltura mwEmbed up to 2.91. It has been rated as problematic. Affected by this issue is some unknown functionality of the file modules/KalturaSupport/components/share/share.js of the component Share Plugin. The manipulation of the argument res leads to cross site scripting. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.92.rc1 is able to address this issue. The name of the patch is 4f11b6f6610acd6d89de5f8be47cf7c610643845. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217664.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.217664 vdb-entry, technical-description
- https://vuldb.com/?ctiid.217664 signature, permissions-required
- https://github.com/kaltura/mwEmbed/pull/4255 exploit, issue-tracking
- https://github.com/kaltura/mwEmbed/commit/4f11b6f6610acd6d89de5f8be47cf7c610643845 patch
- https://github.com/kaltura/mwEmbed/releases/tag/v2.92.rc1 patch