Vulnerability · Published Jan 4, 2023 · Assigned by VulDB
CVE-2022-4876Kaltura mwEmbed DefaultSettings.php cross site scripting
Low 3.5
In plain English
A low-severity cross-site scripting in mwEmbed from Kaltura. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).
Official description
A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
References
- https://vuldb.com/?id.217427 vdb-entry, technical-description
- https://vuldb.com/?ctiid.217427 signature, permissions-required
- https://github.com/kaltura/mwEmbed/pull/4266 issue-tracking
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b patch
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2 patch