Vulnerability · Published May 25, 2023 · Assigned by apache
CVE-2022-46907Apache JSPWiki: XSS Injection points in several plugins
Medium 6.1
In plain English
A medium-severity cross-site scripting in Apache JSPWiki from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 67% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.jspwiki:jspwiki-main | 2.12.0 | GHSA-qvq8-cw7f-m7m4 |
| Maven | org.apache.jspwiki:jspwiki-war | 2.12.0 | GHSA-qvq8-cw7f-m7m4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache JSPWiki | 0 – before Apache JSPWiki up to 2.12.0 |
Weakness: CWE-79