Vulnerability · Published Jan 9, 2023 · Assigned by GitHub_P
CVE-2022-46258Incorrect Authorization in GitHub Enterprise Server leads to Action Workflow modifications without Workflow Scope
Medium 6.5
In plain English
A medium-severity incorrect authorization in GitHub Enterprise Server from GitHub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities).
Official description
An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GitHub | GitHub Enterprise Server | 3.3 – before 3.3.163.4 – before 3.4.113.5 – before 3.5.83.6 – before 3.6.4 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
References
- https://docs.github.com/en/enterprise-server%403.3/admin/release-notes#3.3.16
- https://docs.github.com/en/enterprise-server%403.4/admin/release-notes#3.4.11
- https://docs.github.com/en/enterprise-server%403.5/admin/release-notes#3.5.8
- https://docs.github.com/en/enterprise-server%403.6/admin/release-notes#3.6.4