Vulnerability · Published Dec 14, 2022 · Assigned by VulDB

CVE-2022-4495collective.dms.basecontent column.py renderCell cross site scripting

Low 3.5

In plain English

A low-severity cross-site scripting in collective.dms.basecontent. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.5Low
Exploit odds (30 days)0.5%top 55.3% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known

Official description

A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent up to 1.6. This issue affects the function renderCell of the file src/collective/dms/basecontent/browser/column.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.7 is able to address this issue. The name of the patch is 6c4d616fcc771822a14ebae5e23f3f6d96d134bd. It is recommended to upgrade the affected component. The identifier VDB-215813 was assigned to this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIcollective-dms-basecontent1.7GHSA-r48c-4vfj-h426
PyPIcollective-dms-basecontent1.7PYSEC-2022-42989

Affected products (as reported)

VendorProductVersions
n/a collective.dms.basecontent 1.01.11.21.31.41.51.6

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

References