Vulnerability · Published Oct 13, 2022 · Assigned by apache

CVE-2022-42889Apache Commons Text prior to 1.10.0 allows RCE when applied to untrusted input due to insecure interpolation defaults

Critical 9.8

In plain English

A critical-severity security flaw in Apache Commons Text from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 99.9% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS NVD)9.8Critical
Exploit odds (30 days)99.9%top 0.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling2Metasploit, Public PoC

Official description

Apache Commons Text performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.text.lookup.StringLookup that performs the interpolation. Starting with version 1.5 and continuing through 1.9, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Text 1.10.0, which disables the problematic interpolators by default.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12commons-text1.10.0-1DEBIAN-CVE-2022-42889
Debian:13commons-text1.10.0-1DEBIAN-CVE-2022-42889
Debian:14commons-text1.10.0-1DEBIAN-CVE-2022-42889
Mavencom.guicedee.services:commons-textno fix listedGHSA-599f-7c49-w659
Mavenorg.apache.commons:commons-text1.10.0GHSA-599f-7c49-w659
Ubuntu:22.04:LTScommons-textno fix listedUBUNTU-CVE-2022-42889

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Commons Text unspecified – through 1.91.5 – before Apache Commons Text*

References