Actively exploited · Published Dec 15, 2022 · Assigned by apple
CVE-2022-42856
High 8.8 Exploited
In plain English
A high-severity type confusion in tvOS from Apple. Attackers are actively exploiting it in the wild (listed by CISA on December 14, 2022). The chance it is exploited in the next 30 days is estimated at 8.5% (higher than 95% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
CISA guidance
Apply updates per vendor instructions.
Federal agencies must remediate by Jan 4, 2023.
Official description
A type confusion issue was addressed with improved state handling. This issue is fixed in Safari 16.2, tvOS 16.2, macOS Ventura 13.1, iOS 15.7.2 and iPadOS 15.7.2, iOS 16.1.2. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS released before iOS 15.1..
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | webkit2gtk3 | 2.36.7-1.el8_7.1 | ALSA-2023:0016 |
| AlmaLinux:9 | webkit2gtk3 | 2.36.7-1.el9_1.1 | ALSA-2023:0021 |
| AlmaLinux:8 | webkit2gtk3-devel | 2.36.7-1.el8_7.1 | ALSA-2023:0016 |
| AlmaLinux:9 | webkit2gtk3-devel | 2.36.7-1.el9_1.1 | ALSA-2023:0021 |
| AlmaLinux:8 | webkit2gtk3-jsc | 2.36.7-1.el8_7.1 | ALSA-2023:0016 |
| AlmaLinux:9 | webkit2gtk3-jsc | 2.36.7-1.el9_1.1 | ALSA-2023:0021 |
| AlmaLinux:8 | webkit2gtk3-jsc-devel | 2.36.7-1.el8_7.1 | ALSA-2023:0016 |
| AlmaLinux:9 | webkit2gtk3-jsc-devel | 2.36.7-1.el9_1.1 | ALSA-2023:0021 |
| Debian:12 | webkit2gtk | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Debian:13 | webkit2gtk | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Debian:14 | webkit2gtk | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Debian:12 | wpewebkit | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Debian:13 | wpewebkit | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Debian:14 | wpewebkit | 2.38.3-1 | DEBIAN-CVE-2022-42856 |
| Rocky Linux:8 | webkit2gtk3 | 0:2.36.7-1.el8_7.1 | RLSA-2023:0016 |
| Rocky Linux:9 | webkit2gtk3 | 0:2.36.7-1.el9_1.1 | RLSA-2023:0021 |
| Ubuntu:22.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2022-42856 |
| Ubuntu:24.04:LTS | qtwebkit-opensource-src | no fix listed | UBUNTU-CVE-2022-42856 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.38.3-0ubuntu0.22.04.1 | UBUNTU-CVE-2022-42856 |
| Ubuntu:22.04:LTS | webkit2gtk | 2.38.3-0ubuntu0.22.04.1 | USN-5797-1 |
| Ubuntu:22.04:LTS | wpewebkit | no fix listed | UBUNTU-CVE-2022-42856 |
Affected products (as reported)
Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://support.apple.com/en-us/HT213535
- https://support.apple.com/en-us/HT213532
- https://support.apple.com/en-us/HT213531
- https://support.apple.com/en-us/HT213516
- https://support.apple.com/en-us/HT213537
- 20221220 APPLE-SA-2022-12-13-2 iOS 15.7.2 and iPadOS 15.7.2 mailing-list
- 20221220 APPLE-SA-2022-12-13-4 macOS Ventura 13.1 mailing-list
- 20221220 APPLE-SA-2022-12-13-3 iOS 16.1.2 mailing-list
- 20221220 APPLE-SA-2022-12-13-7 tvOS 16.2 mailing-list
- 20221220 APPLE-SA-2022-12-13-9 Safari 16.2 mailing-list
- [oss-security] 20221226 WebKitGTK and WPE WebKit Security Advisory WSA-2022-0011 mailing-list
- https://security.gentoo.org/glsa/202305-32
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-42856 government-resource