Vulnerability · Published Jul 12, 2023 · Assigned by apache
CVE-2022-42009Apache Ambari: A malicious authenticated user can remotely execute arbitrary code in the context of the application.
High 8.0
In plain English
A high-severity expression language injection in Apache Ambari from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.0High
Exploit odds (30 days)1.2%top 31.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.ambari:ambari | 2.7.7 | GHSA-m384-pj54-5vr2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Ambari | 2.7.0 – through 2.7.6 |
Weakness: CWE-917 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
References
- https://lists.apache.org/thread/6xf477ttz1oxmg0bx0tpdoz2mlqd7sbc vendor-advisory