Vulnerability · Published Dec 27, 2022 · Assigned by GitHub_M
CVE-2022-41966XStream Denial of Service via stack overflow
High 8.2
In plain English
A high-severity buffer overflow in xstream from x-stream. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 9.3% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
XStream serializes Java objects to XML and back again. Versions prior to 1.4.20 may allow a remote attacker to terminate the application with a stack overflow error, resulting in a denial of service only via manipulation the processed input stream. The attack uses the hash code implementation for collections and maps to force recursive hash calculation causing a stack overflow. This issue is patched in version 1.4.20 which handles the stack overflow and raises an InputManipulationException instead. A potential workaround for users who only use HashMap or HashSet and whose XML refers these only as default map or set, is to change the default implementation of java.util.Map and java.util per the code example in the referenced advisory. However, this implies that your application does not care about the implementation of the map and all elements are comparable.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | libxstream-java | 1.4.20-1 | DEBIAN-CVE-2022-41966 |
| Debian:13 | libxstream-java | 1.4.20-1 | DEBIAN-CVE-2022-41966 |
| Debian:14 | libxstream-java | 1.4.20-1 | DEBIAN-CVE-2022-41966 |
| Maven | com.thoughtworks.xstream:xstream | 1.4.20 | GHSA-j563-grx4-pjpv |
| Ubuntu:22.04:LTS | libxstream-java | 1.4.18-2ubuntu0.1 | USN-5946-1 |
| Ubuntu:22.04:LTS | libxstream-java | 1.4.18-2ubuntu0.1 | UBUNTU-CVE-2022-41966 |
| Ubuntu:24.04:LTS | libxstream-java | no fix listed | UBUNTU-CVE-2022-41966 |
| Ubuntu:25.10 | libxstream-java | no fix listed | UBUNTU-CVE-2022-41966 |
| Ubuntu:26.04:LTS | libxstream-java | no fix listed | UBUNTU-CVE-2022-41966 |
| Ubuntu:26.10 | libxstream-java | no fix listed | UBUNTU-CVE-2022-41966 |
Affected products (as reported)
Weakness: CWE-120, CWE-121, CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H