Vulnerability · Published Nov 28, 2022 · Assigned by GitHub_M
CVE-2022-41957muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference
High 7.5
In plain English
A high-severity security flaw in MuhammaraJS from julianhille. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 67% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | hummus | no fix listed | GHSA-2r7v-cmch-5x26 |
| npm | muhammara | 3.4.0 | GHSA-2r7v-cmch-5x26 |
| npm | muhammara | 2.6.2 | GHSA-2r7v-cmch-5x26 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| julianhille | MuhammaraJS | < 2.6.2>= 3.0.0, < 3.4.0 |
Weakness: CWE-690 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H