Vulnerability · Published Nov 23, 2022 · Assigned by GitHub_M

CVE-2022-41925Tailscale daemon is vulnerable to information disclosure via CSRF

Low 3.8

In plain English

A low-severity cross-site request forgery in tailscale from tailscale. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.0)3.8Low
Exploit odds (30 days)0.6%top 52.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

A vulnerability identified in the Tailscale client allows a malicious website to access the peer API, which can then be used to access Tailscale environment variables. In the Tailscale client, the peer API was vulnerable to DNS rebinding. This allowed an attacker-controlled website visited by the node to rebind DNS for the peer API to an attacker-controlled DNS server, and then making peer API requests in the client, including accessing the node’s Tailscale environment variables. An attacker with access to the peer API on a node could use that access to read the node’s environment variables, including any credentials or secrets stored in environment variables. This may include Tailscale authentication keys, which could then be used to add new nodes to the user’s tailnet. The peer API access could also be used to learn of other nodes in the tailnet or send files via Taildrop. All Tailscale clients prior to version v1.32.3 are affected. Upgrade to v1.32.3 or later to remediate the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24tailscale1.32.3-r0ALPINE-CVE-2022-41925
Gotailscale.com1.32.3GO-2022-1119
Gotailscale.com/cmd1.32.3GHSA-qccm-wmcq-pwr6

Affected products (as reported)

VendorProductVersions
tailscale tailscale < 1.32.3

Weakness: CWE-352 · Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

References