Vulnerability · Published Nov 23, 2022 · Assigned by GitHub_M

CVE-2022-41922yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input

High 8.1

In plain English

A high-severity unsafe deserialization in yii from yiisoft. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 69% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.2%top 30.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistyiisoft/yii1.1.27GHSA-442f-wcwq-fpcf

Affected products (as reported)

VendorProductVersions
yiisoft yii < 1.1.27

Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References