Vulnerability · Published Nov 11, 2022 · Assigned by GitHub_M

CVE-2022-41905wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

High 8.2

In plain English

A high-severity cross-site scripting in wsgidav from mar10. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.2High
Exploit odds (30 days)0.4%top 68.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIwsgidav4.1.0GHSA-xx6g-jj35-pxjv
PyPIwsgidav4.1.0PYSEC-2022-43018

Affected products (as reported)

VendorProductVersions
mar10 wsgidav >= 3.0.0a1, < 4.1.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

References