Vulnerability · Published Oct 11, 2022 · Assigned by mitre
CVE-2022-41606
Medium 6.5
In plain English
A medium-severity improper input validation in the github.com/hashicorp/nomad package (Go). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 41.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
HashiCorp Nomad and Nomad Enterprise 1.0.2 up to 1.2.12, and 1.3.5 jobs submitted with an artifact stanza using invalid S3 or GCS URLs can be used to crash client agents. Fixed in 1.2.13, 1.3.6, and 1.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/hashicorp/nomad | 1.2.13 | GHSA-7v3g-4878-5qrf |
| Go | github.com/hashicorp/nomad | 1.3.6 | GHSA-7v3g-4878-5qrf |
| Go | github.com/hashicorp/nomad | 1.2.13, 1.3.6 | GO-2022-1062 |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H