Vulnerability · Published Oct 6, 2022 · Assigned by mitre
CVE-2022-41556
High 7.5
In plain English
A high-severity security flaw in the lighttpd package (Alpine). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 3.8% (higher than 90% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS NVD)7.5High
Exploit odds (30 days)3.8%top 9.9% of all CVEs
Exploited in the wildNo reportsnot in CISA KEV
Attack toolingNoneno public tooling known
Official description
A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | lighttpd | 1.4.67-r0 | ALPINE-CVE-2022-41556 |
| Alpine:v3.21 | lighttpd | 1.4.67-r0 | ALPINE-CVE-2022-41556 |
| Alpine:v3.22 | lighttpd | 1.4.67-r0 | ALPINE-CVE-2022-41556 |
| Alpine:v3.23 | lighttpd | 1.4.67-r0 | ALPINE-CVE-2022-41556 |
| Alpine:v3.24 | lighttpd | 1.4.67-r0 | ALPINE-CVE-2022-41556 |
| Debian:12 | lighttpd | 1.4.67-1 | DEBIAN-CVE-2022-41556 |
| Debian:13 | lighttpd | 1.4.67-1 | DEBIAN-CVE-2022-41556 |
| Debian:14 | lighttpd | 1.4.67-1 | DEBIAN-CVE-2022-41556 |
| Ubuntu:22.04:LTS | lighttpd | 1.4.63-1ubuntu3.1 | UBUNTU-CVE-2022-41556 |
| Ubuntu:22.04:LTS | lighttpd | 1.4.63-1ubuntu3.1 | USN-5903-1 |