Vulnerability · Published Dec 25, 2022 · Assigned by mitre
CVE-2022-41317
Medium 6.5
In plain English
A medium-severity security flaw in the squid package (Alpine). There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 79% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.8%top 20.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
An issue was discovered in Squid 4.9 through 4.17 and 5.0.6 through 5.6. Due to inconsistent handling of internal URIs, there can be Exposure of Sensitive Information about clients using the proxy via an HTTPS request to an internal cache manager URL. This is fixed in 5.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | squid | 5.7-r0 | ALPINE-CVE-2022-41317 |
| Alpine:v3.21 | squid | 5.7-r0 | ALPINE-CVE-2022-41317 |
| Alpine:v3.22 | squid | 5.7-r0 | ALPINE-CVE-2022-41317 |
| Alpine:v3.23 | squid | 5.7-r0 | ALPINE-CVE-2022-41317 |
| Alpine:v3.24 | squid | 5.7-r0 | ALPINE-CVE-2022-41317 |
| Debian:12 | squid | 5.7-1 | DEBIAN-CVE-2022-41317 |
| Debian:13 | squid | 5.7-1 | DEBIAN-CVE-2022-41317 |
| Debian:14 | squid | 5.7-1 | DEBIAN-CVE-2022-41317 |
| Ubuntu:22.04:LTS | squid | 5.2-1ubuntu4.2 | UBUNTU-CVE-2022-41317 |
| Ubuntu:22.04:LTS | squid | 5.2-1ubuntu4.2 | USN-5641-1 |
Affected products (as reported)
Weakness: CWE-697 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N