Vulnerability · Published Nov 13, 2022 · Assigned by VulDB
CVE-2022-3978NodeBB abort cross-site request forgery
Medium 4.3
In plain English
A medium-severity incorrect authorization in NodeBB from unspecified. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | nodebb | 2.5.8 | GHSA-5gwx-wf9g-r5mx |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| unspecified | NodeBB | 2.5.02.5.12.5.22.5.32.5.42.5.52.5.62.5.7 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N